summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@aliftype.com>2022-10-01 13:03:11 +0200
committerخالد حسني <khaled@aliftype.com>2022-10-01 14:21:28 +0200
commit5aad191eae5366c6892dc51b85171bbe3db7b60d (patch)
tree937d944d505bce9cf28157b30ef93ba78ab8a534 /configure.ac
parentb7e7ae77f55e41dae2231b04062cf037f7f9b13f (diff)
Revert "Use libo_CHECK_SYSTEM_MODULE for eot"
This reverts commit ce54ba96f38b4af3aab1a7064078ee406eb021c6 and the followup commit 88c511981e31c73dced95b5dc3c200fdf2a4e932. Both effectively disabled enabling libeot support. See also: https://lists.freedesktop.org/archives/libreoffice/2022-August/089205.html Change-Id: I54780c69ca83b230b0c9b3b18065782fb5626da6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/140838 Tested-by: René Engelhard <rene@debian.org> Reviewed-by: René Engelhard <rene@debian.org> Tested-by: Jenkins Reviewed-by: خالد حسني <khaled@aliftype.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ab2c744fb26d..112e180d91a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -953,7 +953,6 @@ cygwin*|wsl*)
using_x11=no
test_unix_dlapi=no
test_openldap=no
- test_eot=no
enable_pagein=no
build_skia=yes
_os=WINNT
@@ -974,7 +973,6 @@ darwin*) # macOS
using_x11=no
build_skia=yes
enable_pagein=no
- test_eot=no
if test -n "$LODE_HOME" ; then
mac_sanitize_path
AC_MSG_NOTICE([sanitized the PATH to $PATH])
@@ -1785,6 +1783,11 @@ libo_FUZZ_ARG_ENABLE(gstreamer-1-0,
[Disable building with the gstreamer 1.0 avmedia backend.]),
,test "${enable_gstreamer_1_0+set}" = set || enable_gstreamer_1_0=yes)
+libo_FUZZ_ARG_ENABLE([eot],
+ [AS_HELP_STRING([--enable-eot],
+ [Enable support for Embedded OpenType fonts.])],
+,test "${enable_eot+set}" = set || enable_eot=no)
+
libo_FUZZ_ARG_ENABLE(cve-tests,
AS_HELP_STRING([--disable-cve-tests],
[Prevent CVE tests to be executed]),
@@ -9573,7 +9576,18 @@ dnl Check for system xmlsec
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([xmlsec], [XMLSEC], [xmlsec1-nss >= 1.2.28])
-libo_CHECK_SYSTEM_MODULE([eot],[LIBEOT],[libeot >= 0.01],disabled)
+AC_MSG_CHECKING([whether to enable Embedded OpenType support])
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_eot" = "yes"; then
+ ENABLE_EOT="TRUE"
+ AC_DEFINE([ENABLE_EOT])
+ AC_MSG_RESULT([yes])
+
+ libo_CHECK_SYSTEM_MODULE([libeot],[LIBEOT],[libeot >= 0.01])
+else
+ ENABLE_EOT=
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST([ENABLE_EOT])
dnl ===================================================================
dnl Check for DLP libs