summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-04-17 16:28:28 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-04-17 19:57:20 +0200
commitb1982dfa0281e7af5872f62b4b507fe639ed3973 (patch)
tree9211d30004dc7687b0b3afa8facb842c2e8fa079 /configure.ac
parent141e0449fdab89384564659191492b698e4b13d8 (diff)
No need for HAVE_GCC_DEPRECATED_MESSAGE
GCC appears to support it at least since <https://gcc.gnu.org/git/ ?p=gcc.git;a=commit;h=9b86d6bb25587db93a322bf5778e9892aaa8b776> "re PR c/36892 (Support __attribute__((deprecated("text string"))))" in GCC 4.5, and Clang appears to support it at least since <https://github.com/llvm/llvm-project/ commit/c7890fed01f8c8accba188236d781af26845cb2c> "Add an optional string argument to DeprecatedAttr for Fix-It" in Clang 3.9. Change-Id: If0939c692703522523d1953c3793070e0f808973 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92455 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 309b298398c8..c3ef52dc65c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6304,17 +6304,6 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING([whether $CC_BASE supports __attribute__((deprecated(message)))])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- __attribute__((deprecated("test"))) void f();
- ])], [
- AC_DEFINE([HAVE_GCC_DEPRECATED_MESSAGE],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
- CFLAGS=$save_CFLAGS
-
AC_MSG_CHECKING([whether $CXX_BASE defines __base_class_type_info in cxxabi.h])
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([