summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2023-01-25 10:08:48 +0100
committerMichael Weghorn <m.weghorn@posteo.de>2023-02-16 20:32:34 +0000
commitd07962c0b1395aa5edf21ba2ddbbc0574bf464b7 (patch)
tree450a5e7d712cc31ae33a228e980ea077f224d8d9 /configure.ac
parent8c1a3422dbce3236ca310e0541ca9d1ead2fc166 (diff)
android: Use actual Android API level for minSdkVersion, nss
When an Android API level is explicitly set with the `--with-android-api-level` switch introduced in commit 4c0bccbb21ba022fd9d630eb1d9ae34673b4dc11 Date: Thu Jul 4 09:06:49 2019 +0200 android: Allow specification of the API level. , use that for the minSdkVersion for the Android Viewer app and the API level for the NSS build, rather than leaving that hard-coded at API level 16. Building with a newer API level means that the app won't run on devices with older API levels. With this in place, this will be recognized at install time (installation will fail: INSTALL_FAILED_OLDER_SDK) rather than crashing at run time. Change-Id: Id6047b768d265b965696f3a3161d7828e5f3696e Reviewed-on: https://gerrit.libreoffice.org/c/core/+/146127 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07d25c85b781..0d4dca6516b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -799,6 +799,7 @@ if test -n "$with_android_ndk"; then
fi
fi
AC_SUBST(ANDROID_NDK_DIR)
+AC_SUBST(ANDROID_API_LEVEL)
AC_SUBST(ANDROID_APP_ABI)
AC_SUBST(ANDROID_GCC_TOOLCHAIN_VERSION)