summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2023-05-23 15:16:26 +0200
committerCaolán McNamara <caolan.mcnamara@collabora.com>2023-11-09 17:13:34 +0100
commitd9ccfb162f211565ea8e98ae58ab4199eac22452 (patch)
tree18a63be777bcd982b479e7c88283ac505334d799 /configure.ac
parentec3ffe62685f9c5e944ae0924a9963fbe016a706 (diff)
replace license in package header to MPL-2.0 in case of MPL subset
Change-Id: I0ba75ff7da69a3a45afde3252de272aa18f69932 (cherry picked from commit fb228423017d2fce4491232f66299be6aa78b3d9) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/158672 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolan.mcnamara@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65cedd785904..39767d4e9da9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14732,6 +14732,7 @@ dnl ===================================================================
AC_MSG_CHECKING([MPL subset])
MPL_SUBSET=
+LICENSE="LGPL"
if test "$enable_mpl_subset" = "yes"; then
mpl_error_string=
@@ -14783,12 +14784,14 @@ if test "$enable_mpl_subset" = "yes"; then
fi
MPL_SUBSET="TRUE"
+ LICENSE="MPL-2.0"
AC_DEFINE(MPL_HAVE_SUBSET)
AC_MSG_RESULT([only])
else
AC_MSG_RESULT([no restrictions])
fi
AC_SUBST(MPL_SUBSET)
+AC_SUBST(LICENSE)
dnl ===================================================================