summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2021-10-13 00:37:41 +0200
committerLuboš Luňák <l.lunak@collabora.com>2021-10-13 11:06:46 +0200
commitdb51f08247961a9dd8d2a083f1d213b49d8ee2b7 (patch)
treef81697b28c403b71a808aaeeab7eb5fe71108d8d /configure.ac
parent4fed3b2ed15730fcb7a5b7e0ef09d77bd40436e6 (diff)
do not imply --enable-gdb-index just for --enable-symbols
The original idea was to enable gdb index for debug builds, but this by mistake enabled it even for optimized symbol builds. Those are presumably mostly release builds that also provide debug symbols for distributions, but there having a gdb index seems to be a waste of space. Change-Id: I585941aaed1af9e2e4ad85bb278c99c6f12cd858 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/123538 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1bffda90f816..62d74e99db55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4649,7 +4649,7 @@ AC_SUBST(HAVE_CLANG_DEBUG_INFO_KIND_CONSTRUCTOR)
ENABLE_GDB_INDEX=
if test "$enable_gdb_index" != "no"; then
dnl Currently by default enabled only on Linux, feel free to set test_gdb_index above also for other platforms.
- if test "$enable_gdb_index" = yes -o \( "$test_gdb_index" = "yes" -o -n "$ENABLE_DEBUG$ENABLE_DBGUTIL" \); then
+ if test "$enable_gdb_index" = yes -o \( "$test_gdb_index" = "yes" -a -n "$ENABLE_DEBUG$ENABLE_DBGUTIL" \); then
AC_MSG_CHECKING([whether $CC_BASE supports -ggnu-pubnames])
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror -ggnu-pubnames"