summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2023-11-11 16:26:55 +0300
committerMike Kaganski <mike.kaganski@collabora.com>2023-11-11 16:40:47 +0100
commit8d6209d92dedf46d6d7c084b54dd1ebcbe55f1c4 (patch)
treeafff0c8c87bf09e4b482254c627f22b3d2f54798 /configure.ac
parent3b74fa43f537f471b1b87741d703f2696ed24510 (diff)
Finally remove superfluous --with-theme=default option
... as suggested in commit 7524f45e0a2b86dc418f0eb76df89dbdbecfafd3 (remove superfluous --with-theme=default option, 2014-08-22). Change-Id: Iddd1e000039846023c3a4e2ebd73b0010d70c706 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/159320 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 15e7c781e993..ef52e39bc261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13498,8 +13498,7 @@ fi
WITH_THEMES=""
if test "x$with_theme" != "xno"; then
- with_theme_sorted=`echo $with_theme|sed 's/\bdefault\b/colibre/g'|tr '\ ' '\n'|sort -u`
- for theme in $with_theme_sorted; do
+ for theme in $with_theme; do
case $theme in
breeze|breeze_dark|breeze_dark_svg|breeze_svg|colibre|colibre_svg|colibre_dark|colibre_dark_svg|elementary|elementary_svg|karasa_jaga|karasa_jaga_svg|sifr|sifr_svg|sifr_dark|sifr_dark_svg|sukapura|sukapura_dark|sukapura_dark_svg|sukapura_svg) WITH_THEMES="${WITH_THEMES:+$WITH_THEMES }$theme" ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
@@ -13508,13 +13507,6 @@ if test "x$with_theme" != "xno"; then
fi
AC_MSG_RESULT([$WITH_THEMES])
AC_SUBST([WITH_THEMES])
-# FIXME: remove this, and the convenience default->colibre remapping after a grace period
-for theme in $with_theme; do
- case $theme in
- default) AC_MSG_WARN([--with-theme=default is deprecated and will be removed, use --with-theme=colibre]) ;;
- *) ;;
- esac
-done
###############################################################################
# Extensions checking