summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-10-28 11:56:16 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2021-10-31 22:05:16 +0100
commitc0c937d1ff2a47c55b597e10c0f0055e5bfda7e0 (patch)
treeb18c62719fa8400e56f248d2a798bb937634ac6b /configure.ac
parent359a17d0215d36a441688ac3261af04f20a03c6c (diff)
Echo cross-toolset configure options
... just like autogen.sh does. Change-Id: I30ee6b4043c138d7c1e8de154b33fbc7528c34dd Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124439 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f2062daf62ac..cecc4993641f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5507,10 +5507,9 @@ if test "$cross_compiling" = "yes"; then
test -n "$with_help" -a "$with_help" != "no" && sub_conf_opts="$sub_conf_opts --with-help=$with_help"
test "$enable_extensions" = yes || sub_conf_opts="$sub_conf_opts --disable-extensions"
test "$enable_wasm_strip" = "yes" && sub_conf_opts="$sub_conf_opts --enable-wasm-strip"
- sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
# Don't bother having configure look for stuff not needed for the build platform anyway
- ./configure \
+ sub_conf_defaults=" \
--build="$build_alias" \
--disable-cairo-canvas \
--disable-cups \
@@ -5532,7 +5531,12 @@ if test "$cross_compiling" = "yes"; then
--with-parallelism="$with_parallelism" \
--with-theme="$with_theme" \
--with-tls=openssl \
+"
+ echo " Running CONF-FOR-BUILD/configure" $sub_conf_defaults $sub_conf_opts $with_build_platform_configure_options --srcdir=$srcdir
+ ./configure \
+ $sub_conf_defaults \
$sub_conf_opts \
+ $with_build_platform_configure_options \
--srcdir=$srcdir \
2>&1 | sed -e 's/^/ /'
if test [${PIPESTATUS[0]}] -ne 0; then