summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-05-19 12:16:42 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2021-12-03 06:46:24 +0100
commitfb308c193bc9f0d07ad2cccd5a0b239f86cbe442 (patch)
tree11cbb10810a968567b3c215efb353acb4ca23194 /configure.ac
parent6ac1e9e7f0be23b529992c268d2c563fe40fff76 (diff)
Fix --disable-scripting for DESKTOP build
Unfortunatly we cannot add --disable-scripting to sub_conf_defaults, because Java currently has no equivalent to the PYTHON_FOR_BUILD setting. Change-Id: I89938a17307a363f5de808200914940503312829 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126186 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e7ea00ef8cb3..80ce42b33fcd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5482,9 +5482,10 @@ if test "$cross_compiling" = "yes"; then
test -n "$enable_ccache" && sub_conf_opts="$sub_conf_opts --enable-ccache=$enable_ccache"
test -n "$with_ant_home" && sub_conf_opts="$sub_conf_opts --with-ant-home=$with_ant_home"
test "$with_junit" = "no" && sub_conf_opts="$sub_conf_opts --without-junit"
+ # While we don't need scripting support, we don't have a PYTHON_FOR_BUILD Java equivalent, so must enable scripting for Java
if test -n "$ENABLE_JAVA"; then
case "$_os" in
- iOS) sub_conf_opts="$sub_conf_opts --without-java" ;; # force it off, like it used to be
+ iOS) sub_conf_opts="$sub_conf_opts --disable-scripting" ;; # force it off, as it used to be
Android)
# Hack for Android - the build doesn't need a host JDK, so just forward to build for convenience
test -n "$with_jdk_home" && sub_conf_opts="$sub_conf_opts --with-jdk-home=$with_jdk_home"
@@ -5496,7 +5497,7 @@ if test "$cross_compiling" = "yes"; then
;;
esac
else
- sub_conf_opts="$sub_conf_opts --without-java"
+ sub_conf_opts="$sub_conf_opts --disable-scripting"
fi
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
@@ -5573,7 +5574,6 @@ if test "$cross_compiling" = "yes"; then
OPENSSL
ORCUS
PYTHON
- SCRIPTING
ZLIB
"
# converts BUILD_TYPE and PERMITTED_BUILD_TARGETS into non-whitespace,