summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2017-02-10 12:27:07 +0000
committerCaolán McNamara <caolanm@redhat.com>2017-02-10 14:03:37 +0000
commit55e203a0c6c8c6f0c58025efd7c9079e27b438c9 (patch)
tree8bed0a38fdc6eac12b6ec4ef5ca221a39baa74ed /configure.ac
parent9960002118fda6515c6985bc2908a69c0568a71d (diff)
add --disable-pdfium
Change-Id: I9137dc0030c3c752ffc0931721bf6b0013309d39
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f23f29c5412..58ece8aae510 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1033,6 +1033,11 @@ libo_FUZZ_ARG_ENABLE(pdfimport,
[Disable building the PDF import feature.])
)
+libo_FUZZ_ARG_ENABLE(pdfium,
+ AS_HELP_STRING([--disable-pdfium],
+ [Disable building PDFium.])
+)
+
###############################################################################
dnl ---------- *** ----------
@@ -10634,6 +10639,18 @@ AC_SUBST(SYSTEM_POPPLER)
AC_SUBST(POPPLER_CFLAGS)
AC_SUBST(POPPLER_LIBS)
+# pdf import?
+AC_MSG_CHECKING([whether to build PDFium])
+ENABLE_PDFIUM=
+if test -z "$enable_pdfium" -o "$enable_pdfium" = yes; then
+ AC_MSG_RESULT([yes])
+ ENABLE_PDFIUM=TRUE
+ BUILD_TYPE="$BUILD_TYPE PDFIUM"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_PDFIUM)
+
SYSTEM_GPGME=
if test "$_os" = "Linux"; then
dnl ===================================================================