summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2020-03-25 16:42:31 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2020-03-25 16:42:31 +0100
commit9ea80bb272c6bb9f6a29cc7320a7e4d42fa37eda (patch)
tree7cf021fe57daadadcf6cf33f0b2ba6312c26d509 /configure.ac
parent0dc21508e34b42167dda73da9689cdbbfd4e5cb1 (diff)
Remove option to build against system Python
With python3: upgrade to release 3.5.9 we only support internal python builds on this LTS branch. Change-Id: Ib7f9ab86c767b76a94b350b8ab0bcd413a8b2a62
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 02cfb83d7dd2..4accf14e1215 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8136,21 +8136,12 @@ no|disable)
AC_MSG_RESULT([system])
enable_python=system
else
- # Unset variables set by the above AM_PATH_PYTHON so that
- # we actually do check anew.
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
- AM_PATH_PYTHON([3.3],, [:])
- if test "$PYTHON" = ":"; then
- if test -z "$PYTHON_FOR_BUILD"; then
- AC_MSG_RESULT([fully internal])
- else
- AC_MSG_RESULT([internal])
- fi
- enable_python=internal
+ if test -z "$PYTHON_FOR_BUILD"; then
+ AC_MSG_RESULT([fully internal])
else
- AC_MSG_RESULT([system])
- enable_python=system
+ AC_MSG_RESULT([internal])
fi
+ enable_python=internal
fi
;;
internal)