summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuergen Funk <juergen.funk_ml@cib.de>2019-11-04 10:42:06 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2020-04-21 17:17:54 +0200
commitc9408eceb0274c6c3bc6d726433af990bf34995b (patch)
treeeb169452ec2dbee9bf177e6a2ee40c8e2010e9c9 /configure.ac
parent984a240975b87eff10ccda394de9e7ea0078ed30 (diff)
tdf#127711 - A runtime-switch for the MiniCrashDump and associated changes
- add CrashDumpEnable to soffice.ini - also check env var CRASH_DUMP_ENABLE (overrides soffice.ini) - make sure _all_ binaries are added to symstore This is a squash of: https://gerrit.libreoffice.org/79273 https://gerrit.libreoffice.org/81989 https://gerrit.libreoffice.org/c/core/+/87260 https://gerrit.libreoffice.org/c/core/+/87261 https://gerrit.libreoffice.org/79272 https://gerrit.libreoffice.org/83171 https://gerrit.libreoffice.org/82751 https://gerrit.libreoffice.org/83066 https://gerrit.libreoffice.org/83726 https://gerrit.libreoffice.org/c/core/+/86465
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4accf14e1215..fe394203bf21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1056,6 +1056,11 @@ libo_FUZZ_ARG_ENABLE(breakpad,
[Enables breakpad for crash reporting.])
)
+libo_FUZZ_ARG_ENABLE(crashdump,
+ AS_HELP_STRING([--disable-crashdump],
+ [Disable dump.ini and dump-file, when --enable-breakpad])
+)
+
AC_ARG_ENABLE(fetch-external,
AS_HELP_STRING([--disable-fetch-external],
[Disables fetching external tarballs from web sources.])
@@ -9148,6 +9153,7 @@ AC_SUBST(ICU_UCHAR_TYPE)
dnl ==================================================================
dnl Breakpad
dnl ==================================================================
+DEFAULT_CRASHDUMP_VALUE="true"
AC_MSG_CHECKING([whether to enable breakpad])
if test "$enable_breakpad" != yes; then
AC_MSG_RESULT([no])
@@ -9158,6 +9164,14 @@ else
AC_DEFINE(HAVE_FEATURE_BREAKPAD, 1)
BUILD_TYPE="$BUILD_TYPE BREAKPAD"
+ AC_MSG_CHECKING([for disable crash dump])
+ if test "$enable_crashdump" = no; then
+ DEFAULT_CRASHDUMP_VALUE="false"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
AC_MSG_CHECKING([for crashreport config])
if test "$with_symbol_config" = "no"; then
BREAKPAD_SYMBOL_CONFIG="invalid"
@@ -9170,6 +9184,7 @@ else
AC_SUBST(BREAKPAD_SYMBOL_CONFIG)
fi
AC_SUBST(ENABLE_BREAKPAD)
+AC_SUBST(DEFAULT_CRASHDUMP_VALUE)
dnl ==================================================================
dnl libfuzzer