summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-11-22 14:05:59 +0100
committerMichael Stahl <Michael.Stahl@cib.de>2019-11-22 16:27:42 +0100
commitd750cdb0ee54703760f5a6c0cd4181563e2f5b11 (patch)
tree949cba7004393f81de42ee611c3d3f6a8f69a676 /configure.ac
parent0629491d47101df1646a50258a776c7e4549f957 (diff)
configure: search harder for MSBbuild.exe
If you install Visual Studio 2017 with the Visual Studio 2015 toolset, you don't get the 2015 MSBuild.exe so try to find the 2017 one. Also, DEVENV isn't used during the build so only warn if it's missing. FIXME: this doesn't actually work, msbuild.exe complains about wrong tools version 14.0. Change-Id: I656e37c4c524c0836430ba7d4a092f26817a5017
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9c4a7db50780..92ef5852cc86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3404,6 +3404,13 @@ if test "$_os" = "WINNT"; then
regvalue="$VC_PRODUCT_DIR/../MSBuild/$vcnumwithdot/Bin/amd64"
fi
MSBUILD_PATH=`win_short_path_for_make "$regvalue"`
+ elif test $vcnum = "140"; then
+ if test "$BITNESS_OVERRIDE" = ""; then
+ regvalue="$VC_PRODUCT_DIR/../MSBuild/15.0/Bin"
+ else
+ regvalue="$VC_PRODUCT_DIR/../MSBuild/15.0/Bin/amd64"
+ fi
+ MSBUILD_PATH=`win_short_path_for_make "$regvalue"`
else
AC_MSG_ERROR([No msbuild found, Visual Studio installation broken?])
fi
@@ -3414,7 +3421,7 @@ if test "$_os" = "WINNT"; then
# MSVC 2017 devenv does not start properly from a DOS 8.3 path
DEVENV=$(cygpath -lm "$VC_PRODUCT_DIR/../Common7/IDE/devenv.exe")
if test ! -e "$DEVENV"; then
- AC_MSG_ERROR([No devenv.exe found, Visual Studio installation broken?])
+ AC_MSG_WARN([No devenv.exe found, Visual Studio installation broken?])
fi
dnl ===========================================================