summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-08-17 23:52:10 +0200
committerMichael Stahl <mstahl@redhat.com>2015-08-18 11:19:43 +0000
commitaa93151b9a740582732a06578e04b558beb177c2 (patch)
tree2226d18076c5cb120423179e6265821852e9a069 /configure.ac
parentf54f99febd25b1c86e77747764375a2e53f572c5 (diff)
configure, pyuno: stop claiming our python 3.3.5 is 3.3.3
... and adapt makefiles to automatically rebuild everything that depends on PYTHON_VERSION. Change-Id: If468183e59463503051c2a1526a905dbee9bf4cb Reviewed-on: https://gerrit.libreoffice.org/17818 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2f7dc6e8fc0..5944d23317e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8106,7 +8106,8 @@ internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=3
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.3
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.5
+ AC_DEFINE_UNQUOTED([PYTHON_VERSION_STRING], [L"${PYTHON_VERSION}"])
BUILD_TYPE="$BUILD_TYPE PYTHON"
# Embedded Python dies without Home set
if test "$HOME" = ""; then
@@ -13168,6 +13169,7 @@ AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_CONFIG_HEADERS([config_host/config_oauth2.h])
AC_CONFIG_HEADERS([config_host/config_poppler.h])
+AC_CONFIG_HEADERS([config_host/config_python.h])
AC_OUTPUT
if test "$CROSS_COMPILING" = TRUE; then