summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Thomas <michelphoenix98@gmail.com>2020-02-02 01:03:20 +0530
committerMike Kaganski <mike.kaganski@collabora.com>2020-02-08 06:17:03 +0100
commitc16969b9bc73fdd77e763299d6aea7b614e203e2 (patch)
tree4d73ef247be39d4a5238e362951de3c0858a4c49 /configure.ac
parent1d7b1a15059a77fde9afa14d0b9a508142bfc247 (diff)
tdf#84553 Detect and warn of Windows Antivirus.
Change-Id: I7731cb316306c153ad14bb3d27f39600a44ed9ee Reviewed-on: https://gerrit.libreoffice.org/c/core/+/87811 Reviewed-by: Julien Nabet <serval2412@yahoo.fr> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d4a737aeaeb1..1bccce3578c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12974,6 +12974,21 @@ fi
AC_SUBST(ENABLE_FORMULA_LOGGER)
dnl ===================================================================
+dnl Checking for active Antivirus software.
+dnl ===================================================================
+
+if test $_os = WINNT ; then
+ AC_MSG_CHECKING([for active Antivirus software])
+ ANTIVIRUS_LIST=`cscript.exe //Nologo $SRC_ROOT/antivirusDetection.vbs`
+ if [ [ "$ANTIVIRUS_LIST" != "NOT_FOUND" ] ]; then
+ AC_MSG_RESULT([found])
+ add_warning "To speed up builds and avoid failures in unit tests, it is highly recommended that you exclude the build directories associated with LibreOffice in the following Antivirus software: $ANTIVIRUS_LIST"
+ else
+ AC_MSG_RESULT([not found])
+ fi
+fi
+
+dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================
AC_MSG_NOTICE([setting up the build environment variables...])