summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-12-15 08:54:08 +0100
committerStephan Bergmann <sbergman@redhat.com>2016-12-15 11:24:53 +0000
commit721116c7ade10d76e3ed6832e3988c91427ba431 (patch)
tree5355413a5924885b33bb28b200d20643dee62655 /configure.ac
parentef4b9032de55e6b1b182e4ead1bbe6e590df296e (diff)
Phase out support for HAVE_BROKEN_STATIC_INITIALIZER_LIST
...I'm pondering a change that would make that a hard requirement, and from the comment in configure.ac it looks like only old Clang < 3.4 were affected. Change-Id: I8ef64f759fed1a45d88f94d0e8a60839ad10b263 Reviewed-on: https://gerrit.libreoffice.org/32029 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9c55fe8d2f29..eb2dd83a0dfc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12573,7 +12573,7 @@ LIBS=$save_LIBS
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$broken])
if test "$broken" = yes; then
- AC_DEFINE([HAVE_BROKEN_STATIC_INITIALIZER_LIST])
+ AC_MSG_ERROR([working support for static initializer_list needed])
fi