summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-11-27 23:54:40 +0100
committerMichael Stahl <mstahl@redhat.com>2015-11-30 13:11:10 +0000
commit9ec0e6d9cbb0b61e5cf37917baee31f2af1a2897 (patch)
tree1509d2ccdb5b7aeacd4b6f28037e3d323ace1ba2 /configure.ac
parent883321e141906f5dad47f0021a2fa8cadc3b9a01 (diff)
sd: replace embedded mDNSResponder code with proper external tarball
The diff against the 379.37 release is 2500 lines, one of which actually does anything at runtime (missing va_end()). Change-Id: I1824e61fd4ac6c3ce28084913a2661134a03fd51 Reviewed-on: https://gerrit.libreoffice.org/20248 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a13921411ce..eb569d10afe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11805,7 +11805,10 @@ AC_SUBST(CAIRO_LIBS)
dnl ===================================================================
dnl Test whether to use avahi
dnl ===================================================================
-if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
+if test "$_os" = "WINNT"; then
+ # Windows uses bundled mDNSResponder
+ BUILD_TYPE="$BUILD_TYPE MDNSRESPONDER"
+elif test "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
PKG_CHECK_MODULES([AVAHI], [avahi-client >= 0.6.10],
[ENABLE_AVAHI="TRUE"])
AC_DEFINE(HAVE_FEATURE_AVAHI)