summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-11-07 15:20:43 +0100
committerMichael Stahl <mstahl@redhat.com>2017-11-29 13:09:07 +0100
commitef777ffc384f8363188923ccb10af7b788035632 (patch)
tree90e9cf4bfb1ca62a5f6f7bf65c5d64496e155986 /configure.ac
parenta2b70380c38dca4d075a0a866200096c6d9b4104 (diff)
configure: check that graphviz/dot is found, needed by doxygen
Change-Id: I70937c4c6075ce1814c3be5b8613fb28cd28fc26 Reviewed-on: https://gerrit.libreoffice.org/44408 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 23b1ff84ed5a..fd06712066a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7302,6 +7302,11 @@ else
if test -z "$DOXYGEN"; then
AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
fi
+ if $DOXYGEN -g - | grep -q "HAVE_DOT *= *YES"; then
+ if ! dot -V 2>/dev/null; then
+ AC_MSG_ERROR([dot not found in \$PATH but doxygen defaults to HAVE_DOT=YES; install graphviz or disable its use via --without-doxygen])
+ fi
+ fi
else
AC_MSG_CHECKING([for doxygen])
DOXYGEN=$with_doxygen