summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2016-02-20 19:05:16 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2016-02-20 20:21:06 +0000
commitc37c82319f88e75ba28fd4b7bf26b5ea01846c17 (patch)
treecd388c2e2716b8efe83279cd307ad15ec61ab379 /configure.ac
parentf92f7efead4d6d419500005a3e14aa2fc20f95ac (diff)
wget: don't break on CentOS6 baseline
Where this fancy new no-use-server-timestamps is not yet known. Change-Id: I481c44bb977620400a3dede6191889bbbe5ec74a Reviewed-on: https://gerrit.libreoffice.org/22546 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b6f6f370f01e..0a200e68c540 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12010,9 +12010,9 @@ if test "$enable_fetch_external" != "no"; then
CURL=`which curl 2>/dev/null`
for i in wget /usr/bin/wget /usr/local/bin/wget /usr/sfw/bin/wget /opt/sfw/bin/wget /opt/local/bin/wget; do
- eval "$i --version" > /dev/null 2>&1
- ret=$?
- if test $ret -eq 0; then
+ # wget new enough?
+ $i --help 2> /dev/null | $GREP no-use-server-timestamps 2>&1 > /dev/null
+ if test $? -eq 0; then
WGET=$i
break
fi