summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-02-20 07:57:16 +0100
committerMatúš Kukan <matus.kukan@collabora.com>2014-02-20 11:24:21 +0100
commit193d15277cfa23e6bd03cf723095c00de3c630b1 (patch)
tree4644f26f82e743e359666e13a326df7569415e65 /configure.ac
parent6c6e798d09f490a172033baef2e71c2dc642c60c (diff)
EXTERNAL_WARNINGS_NOT_ERRORS -> ENABLE_WERROR and be "TRUE"/""
It's easier to type 'make ENABLE_WERROR= <module>' if one wants that. Change-Id: I2bb9911259f41ecae27dc110723f3364b3ff09cf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 55761728347c..9c317cc0a7b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4636,13 +4636,12 @@ dnl Set the ENABLE_WERROR variable. (Activate --enable-werror)
dnl ===================================================================
AC_MSG_CHECKING([whether to turn warnings to errors])
if test -n "$enable_werror" -a "$enable_werror" != "no"; then
- EXTERNAL_WARNINGS_NOT_ERRORS="FALSE"
+ ENABLE_WERROR="TRUE"
AC_MSG_RESULT([yes])
else
- EXTERNAL_WARNINGS_NOT_ERRORS="TRUE"
AC_MSG_RESULT([no])
fi
-AC_SUBST(EXTERNAL_WARNINGS_NOT_ERRORS)
+AC_SUBST(ENABLE_WERROR)
dnl Set the ASSERT_ALWAYS_ABORT variable. (Activate --enable-assert-always-abort)
dnl ===================================================================