summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-02-20 23:04:00 +0100
committerMatúš Kukan <matus.kukan@collabora.com>2014-02-21 07:52:24 +0100
commitdbfc495a9ace0865d764dad7404633a12cda2873 (patch)
treeeb695c097fcc97335ead668b927ad756e28b0553 /configure.ac
parentd5951c04195e050d65d44c9578bd339dd41eee2f (diff)
Add config option used when we try to link one huge object file.
In theory, it should not be used, we use it now to mark duplicated symbols from sdi slots as weak. See idl/source/objects/types.cxx. Change-Id: I3c6fccfb96884df6b9e6eb35b8615ba4d66ca208
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e5715681c9b..c858df5a2f5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2530,6 +2530,7 @@ fi
if test -n "$enable_lto" -a "$enable_lto" != "no"; then
ENABLE_LTO="TRUE"
AC_MSG_RESULT([yes])
+ AC_DEFINE(STATIC_LINKING)
else
ENABLE_LTO=""
AC_MSG_RESULT([no])
@@ -12407,6 +12408,7 @@ if test -n "$enable_mergelibs" -a "$enable_mergelibs" != "no"; then
MERGELIBS="CORE"
fi
AC_MSG_RESULT([yes])
+ AC_DEFINE(STATIC_LINKING)
else
AC_MSG_RESULT([no])
fi
@@ -12632,6 +12634,7 @@ AC_CONFIG_HEADERS([config_host/config_orcus.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
+AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_test.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])