summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-10-25 00:53:30 +0300
committerTor Lillqvist <tml@collabora.com>2020-10-25 01:14:10 +0200
commit07f028e706420ddb9a955222fb6ebab046be237a (patch)
treed33067d4021fbbd4ebf3e4d45755ffb3de9680d2 /configure.ac
parent5219c6bd804f626b30a783ec012b24c01911c575 (diff)
Set also ac_cv_{build,host}_{cpu,os} in the case of building for Windows on WSL
Change-Id: I095f5169c0e9969531995ff0b533642aeaae9135 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/104759 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 67d1cbad9d3a..1584480f84bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,11 @@ dnl ===================================================================
# Linux on WSL) trust that.
if test -z "$host" -a -z "$build" -a "`wslsys -v 2>/dev/null`" != ""; then
ac_cv_host="x86_64-pc-wsl"
+ ac_cv_host_cpu="x86_64"
+ ac_cv_host_os="wsl"
ac_cv_build="$ac_cv_host"
+ ac_cv_build_cpu="$ac_cv_host_cpu"
+ ac_cv_build_os="$ac_cv_host_os"
# Emulation of Cygwin's cygpath command for WSL.
cygpath()
@@ -308,6 +312,7 @@ if test -z "$host" -a -z "$build" -a "`wslsys -v 2>/dev/null`" != ""; then
fi
AC_CANONICAL_HOST
+AC_CANONICAL_BUILD
AC_MSG_CHECKING([for product name])
PRODUCTNAME="AC_PACKAGE_NAME"