summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-11-28 22:42:01 +0100
committerMichael Stahl <mstahl@redhat.com>2012-11-28 22:42:55 +0100
commit07f5a7c8ab3c2d36703235b49b66441d804046e1 (patch)
treecf226dd5deeb944050f8c346dc3972a3718cdee8 /configure.ac
parente9ab377670ab12861700f22cb3f88af2e8292ff7 (diff)
liborcus: must be built with -D_GLIBCXX_DEBUG for debug STL
... in --enable-dbgutil mode. Change-Id: I095bc8f29570afd9912a615e98ef05e4249ea8f7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ebf6ff496e1..cbbc0f66afc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3306,6 +3306,11 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_mysql_cppconn=no
fi
+ if test "$with_system_orcus" = "yes"; then
+ AC_MSG_ERROR([--with-system-orcus conflicts with --enable-dbgutil])
+ else
+ with_system_orcus=no
+ fi
else
ENABLE_DBGUTIL=""
# PRODUCT is old concept, still used by build.pl .