summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2012-05-03 14:49:36 +0200
committerPetr Mladek <pmladek@suse.cz>2013-04-30 12:05:22 +0200
commit622005fb5f57719061abdb350fa2eb6fb1c9bdff (patch)
tree04163296e013350267e96ff8eb7085b8c08cf38d /configure.ac
parent07451da679d48fbccb8a7d8c10348d6d4ea5d5cd (diff)
[mono] mono-installation.diff: add mono support
also move mono_loader.*.uno.so into the mono subpackage where it belongs to Conflicts: configure.in bin/distro-install-file-lists solenv/gbuild/extensions/post_AuxTargets.mk Change-Id: I681543edb6a27e16c66badc7e9e11743833f2fe3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0696eb3e70b6..4e89f4eb3dae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1712,6 +1712,16 @@ AC_ARG_WITH(help,
AS_HELP_STRING([--without-help],
[Disable the build of help.]))
+AC_ARG_WITH(mono-gac-root,
+ AS_HELP_STRING([--with-mono-gac-root],
+ [Define the root of the mono GAC. It is especially
+ needed if you are using $DESTDIR and want to
+ preinstall the mono DLLs into the GAC.])
+ [
+ Usage: --with-mono-gac-root=/usr/lib
+ ],
+,)
+
AC_ARG_WITH(java,
AS_HELP_STRING([--with-java],
[Specify the name of the Java interpreter command. Typically "java"
@@ -4970,6 +4980,11 @@ if test "$_os" = "Linux"; then
else
AC_MSG_RESULT([no])
fi
+
+ MONO_GAC_ROOT=
+ if test -n "$with_mono_gac_root" -a "$with_mono_gac_root" != "no" ; then
+ MONO_GAC_ROOT=$with_mono_gac_root
+ fi
fi
AC_SUBST(CSC_PATH)
AC_SUBST(CSC)
@@ -4977,6 +4992,7 @@ AC_SUBST(AL)
AC_SUBST(ENABLE_MONO)
AC_SUBST(MONO_CFLAGS)
AC_SUBST(MONO_LIBS)
+AC_SUBST(MONO_GAC_ROOT)
AC_SUBST(ENABLE_MONO_CLIMAKER)
AC_SUBST(MKBUNDLE)