summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2015-07-06 22:18:52 +0200
committerMichael Stahl <mstahl@redhat.com>2015-07-09 11:13:27 +0000
commit98a61f5b8da500fcefd2e7f0dfb1231bfb87f2fb (patch)
treead2891cd44afcdf876ef80433c53933104fb9be4 /configure.ac
parentae4ec7a75b0048af2fba12953a84fe5b26d89b9a (diff)
Expose devenv make file variable
Change-Id: I502ce280276b6430053f0fbcf9cc3248b6c9b11b Reviewed-on: https://gerrit.libreoffice.org/16801 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aaf1d6a6085c..87d9d76252c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3517,6 +3517,7 @@ find_msvc()
SHOWINCLUDES_PREFIX=
MSBUILD_PATH=
+DEVENV=
if test "$_os" = "WINNT"; then
if test "$WITH_MINGW" != "yes"; then
AC_MSG_CHECKING([Visual C++])
@@ -3565,6 +3566,12 @@ if test "$_os" = "WINNT"; then
MSBUILD_PATH=`win_short_path_for_make "$regvalue"`
fi
+ # Find the version of devenv.exe
+ DEVENV="$VC_PRODUCT_DIR/../Common7/IDE/devenv.exe"
+ if test ! -e "$DEVENV"; then
+ AC_MSG_ERROR([No devenv.exe found, Visual Studio installation broken?])
+ fi
+
dnl ===========================================================
dnl Check for the corresponding mspdb*.dll
dnl ===========================================================
@@ -3746,6 +3753,7 @@ if test "$_os" = "WINNT"; then
fi
fi
AC_SUBST(VCVER)
+AC_SUBST(DEVENV)
PathFormat "$MSPDB_PATH"
MSPDB_PATH="$formatted_path"
AC_SUBST(SHOWINCLUDES_PREFIX)