summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2020-03-23 11:32:36 +0100
committerMichael Stahl <michael.stahl@cib.de>2020-03-23 14:07:01 +0100
commit190f81e34d918da289310a90416f9b6b7be7295f (patch)
tree60f1f10cef11c097d72e51a27be973d3099080b1 /configure.ac
parent71ae87c0cd9f27504c72cc26c339c2a0eb527dde (diff)
configure,gbuild: gla11y fails on Fedora 31
The problem is that the LD_LIBRARY_PATH on the command line causes /usr/bin/python to find LO's libpython*.so*: 18269: find library=libpython3.7m.so.1.0 [0]; searching 18269: search path=.../instdir/program (LD_LIBRARY_PATH) 18269: trying file=.../instdir/program/libpython3.7m.so.1.0 Presumably LD_LIBRARY_PATH is used to find bundled libxml/libxslt. So let's try to disable the broken case where a bundled lxml is used with system python and bundled libxml/libxslt; this cannot work. (regression from 84ef6d82546b044990f4efd57e51e29c6c6565c8) Change-Id: I67aa8250691cae8f899d65f674aa9da23a9d1d7a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/90906 Reviewed-by: Samuel Thibault <sthibault@hypra.fr> Reviewed-by: Michael Stahl <michael.stahl@cib.de> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 57caa0d9ae6b..1cf56da09c0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8951,8 +8951,12 @@ if test "$with_lxml" != no; then
;;
*)
if test "$cross_compiling" != yes -a "x$ac_cv_header_Python_h" = "xyes"; then
- BUILD_TYPE="$BUILD_TYPE LXML"
- AC_MSG_RESULT([no, using internal lxml])
+ if test -n ${SYSTEM_LIBXSLT} -o -n ${SYSTEM_LIBXML}; then
+ AC_MSG_RESULT([no, and no system libxml/libxslt, gla11y will only report widget classes and ids])
+ else
+ BUILD_TYPE="$BUILD_TYPE LXML"
+ AC_MSG_RESULT([no, using internal lxml])
+ fi
else
AC_MSG_RESULT([no, and system does not provide python development headers, gla11y will only report widget classes and ids])
fi