summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2020-02-19 22:54:50 +0100
committerLuboš Luňák <l.lunak@collabora.com>2020-03-23 14:31:04 +0100
commit8512f4ca090c85477a6670438aeefe7fdfcf8a98 (patch)
treed8832c3f2fff7a4f78b40d941f970ec800348718 /configure.ac
parenta58e086ededb8442938e81f971dfae36ef7eb076 (diff)
build nss using their new build system (gyp/ninja-based)
This requires installed ninja, gyp is included as source. This allows nss be built as a parallel build, unlike the old Makefile build system. Since gyp internally uses python, even recursively, this requires more complicated setup in case our internal python is used. Moreover gyp itself seems to be kind of deprecated itself and hasn't been ported to python3 yet, so that needs patching too. So far only easy Unix-like systems are converted, Windows I'll do later, the more complicated systems I'll leave to whoever has access to them. Change-Id: I358baad7690d2aa6df44bafa9244dc7cc828fc3f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/90115 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1cf56da09c0a..34708eab7e8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9667,6 +9667,10 @@ if test $_os != iOS -a "$enable_fuzzers" != "yes"; then
AC_DEFINE(HAVE_FEATURE_NSS)
ENABLE_NSS="TRUE"
AC_DEFINE(ENABLE_NSS)
+ # internal nss uses gyp
+ if test -z "$SYSTEM_NSS"; then
+ BUILD_TYPE="$BUILD_TYPE GYP"
+ fi
elif test $_os != iOS ; then
with_tls=openssl
fi