summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-12-26 19:07:57 +0100
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-12-26 20:16:54 +0000
commitcb1880369989b54bcb5225d726f53c31279fd2e7 (patch)
tree1fce21c67609e45b4944e2b41f21f46daf792532 /configure.ac
parent5c898484f10458ef14735716ffe28da525c9b56d (diff)
fix the egl check again in the internal epoxy case
Change-Id: Ie580b13579fdb71bd8898ae59b915b3842ef8aab Reviewed-on: https://gerrit.libreoffice.org/32434 Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com> Tested-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 12 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 8cf2b2510e97..2b23cf926438 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1633,7 +1633,8 @@ AC_ARG_WITH(system-cairo,
AC_ARG_WITH(system-epoxy,
AS_HELP_STRING([--with-system-epoxy],
[Use epoxy libraries already on system. Happens automatically for
- --enable-gtk3.]))
+ --enable-gtk3.]),,
+ [with_system_epoxy="$with_system_libs"])
AC_ARG_WITH(myspell-dicts,
AS_HELP_STRING([--with-myspell-dicts],
@@ -10083,6 +10084,11 @@ if ! "$TOUCH" -h warn 2>/dev/null > /dev/null; then
fi
dnl ===================================================================
+dnl Check for system epoxy
+dnl ===================================================================
+libo_CHECK_SYSTEM_MODULE([epoxy], [EPOXY], [epoxy >= 1.2], ["-I${WORKDIR}/UnpackedTarball/epoxy/include"])
+
+dnl ===================================================================
dnl Set vcl option: coordinate device in double or sal_Int32
dnl ===================================================================
@@ -10124,6 +10130,11 @@ if test "x$enable_gtk3" = "xyes"; then
GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTK3_LIBS}"
GTK3_LIBS="${filteredlibs}"
+
+ dnl We require egl only for the gtk3 plugin. Otherwise we use glx.
+ if test "$with_system_epoxy" != "yes"; then
+ AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+ fi
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)
@@ -11714,14 +11725,6 @@ AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
dnl ===================================================================
-dnl Check for system epoxy
-dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([epoxy], [EPOXY], [epoxy >= 1.2], ["-I${WORKDIR}/UnpackedTarball/epoxy/include"])
-if test "$with_system_epoxy" = "no"; then
- AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
-fi
-
-dnl ===================================================================
dnl Test whether to use avahi
dnl ===================================================================
if test "$_os" = "WINNT"; then