summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-11-19 17:41:01 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-11-19 17:41:01 +0100
commitf9059d4eee8e53c0a6b531fff16e1fade58cb8b0 (patch)
tree47d4d29b51a96958d5aa0653dc3368e3d1be20e1 /configure.ac
parentb479f7f7675b8a539b35faaa6edcd282e09bba97 (diff)
Key all browser plugin features to --enable-nsplugin
...instead of having them spread across --enable-nsplugin (plug LO into browser windows) and --enable-mozilla (plug browser plugins into LO documents). The ultimate goal is to clean up the various configure options mentioning "mozilla" and WITH_MOZILLA. Change-Id: I6f4b1c3a5701424f586cc1e303af90c9d59a91b6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c85e0e02021a..101ea037d623 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1015,7 +1015,9 @@ AC_ARG_ENABLE(zenity,
AC_ARG_ENABLE(nsplugin,
AS_HELP_STRING([--disable-nsplugin],
- [Do not build nsplugin extension for browser embedding.])
+ [Do not build NPAPI-based plugin features (allowing to plug LibreOffice
+ into browser windows, and to plug browser plugins into LibreOffice
+ documents.])
)
AC_ARG_ENABLE(cups,
@@ -8387,8 +8389,7 @@ if test "$with_system_npapi_headers" = "yes"; then
AC_LANG_POP([C])
else
AC_MSG_RESULT([internal])
- dnl ...but will not be built/used unless ENABLE_NSPLUGIN or WITH_MOZILLA
- dnl is YES
+ dnl ...but will not be built/used unless ENABLE_NSPLUGIN is YES
SYSTEM_NPAPI_HEADERS=NO
fi
AC_SUBST(NPAPI_HEADERS_CFLAGS)