summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2019-07-21 22:44:22 +0000
committerJan-Marek Glogowski <glogow@fbihome.de>2019-07-22 01:40:40 +0200
commit382aceb80d3c0f420d51762e1f88eee2334ff11b (patch)
tree3c1d7feb9a52c585d5362977eff966d5c782ad8d /configure.ac
parentf00ad321cec3923b60604e7417b3661de9c314bf (diff)
Explicitly disable qt5 on Android
Regression from commit d3c6ac6d0f23 ("tdf#125922 rename kde5 to kf5 + plasma5"). Change-Id: I47f2a3977094acc0c7b4ae0af28c3774eba2daca Reviewed-on: https://gerrit.libreoffice.org/76078 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0358692fc1d6..81b2bd497fe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,6 +786,7 @@ linux-android*)
test_freetype=no
test_gtk=no
test_kf5=no
+ test_qt5=no
test_gtk3_kde5=no
test_randr=no
test_xrender=no
@@ -4927,7 +4928,7 @@ if test "$OS" = "HAIKU"; then
test_kf5=yes
fi
-if test "x$enable_kde5" = "xyes"; then
+if test "$test_kf5" = "yes" -a "$enable_kde5" = "yes"; then
AC_MSG_WARN([The kde5 VCL plugin was renamed to kf5. Please update your configuration to use --enable-kf5, as --enable-kde5 will be removed after the next major release!])
add_warning "The kde5 VCL plugin was renamed to kf5. Please update your configuration to use --enable-kf5, as --enable-kde5 will be removed after the next major release!"
test_kf5=yes
@@ -4937,7 +4938,7 @@ if test "$test_kf5" = "yes"; then
test_qt5=yes
fi
-if test "$test_kf5" = "yes"; then
+if test "$test_kf5" = "yes" -a "$enable_kf5" = "yes"; then
if test "$enable_qt5" = "no"; then
AC_MSG_ERROR([KF5 support depends on QT5, so it conflicts with --disable-qt5])
else