summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArmin Le Grand (Allotropia) <Armin.Le.Grand@me.com>2021-04-30 17:26:41 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2022-01-20 12:28:54 +0100
commit02140554ee1d70b219a42546191e2219d58be4b0 (patch)
tree3dd419dbdd0c23676c7f749bd8a83d09ad26c8bd /configure.ac
parent02634fb7c7e8dc613ffc3717bb244f85cf81a7c6 (diff)
WASM --enable-wasm-strip now skips lots of LO code
... resulting in a stripped-down, Writer-only build to decrease the resulting WASM bytecode size. It removes the following code from the build: * All other major modules: Base, Calc, Chart, Draw, Impress and Math and related writerperfect filters * The premultiply tables * The (auto-)recovery functionality * All accessibility (but not the accessibility document checker) * The LanguageGuess component * EPUB support * The start center / BackingWindow * The TipOfTheDay functionality * The splash screen communication Currently crashs with anything different then soffice --writer. Closing the document also still crashes. FYI: many of these features are now behind ENABLE_WASM_STRIP_* defines, but they normally don't work on their own, globally! That's because we started with stripping the main components. Change-Id: Ib9c0f9452815910c0a2aceaf142ba1ad4a9cb0d7 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126182 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c168e154c4d..8aa4a58ed81e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3015,6 +3015,21 @@ if test "$enable_wasm_strip" = "yes"; then
test "${with_fonts+set}" = set || with_fonts=yes
test "${with_locales+set}" = set || with_locales=en
+
+ AC_DEFINE(ENABLE_WASM_STRIP_ACCESSIBILITY)
+ AC_DEFINE(ENABLE_WASM_STRIP_CANVAS)
+ AC_DEFINE(ENABLE_WASM_STRIP_CHART)
+ AC_DEFINE(ENABLE_WASM_STRIP_DBACCESS)
+ AC_DEFINE(ENABLE_WASM_STRIP_EPUB)
+ AC_DEFINE(ENABLE_WASM_STRIP_EXTRA)
+ AC_DEFINE(ENABLE_WASM_STRIP_GUESSLANG)
+# AC_DEFINE(ENABLE_WASM_STRIP_HUNSPELL)
+ AC_DEFINE(ENABLE_WASM_STRIP_PINGUSER)
+ AC_DEFINE(ENABLE_WASM_STRIP_PREMULTIPLY)
+ AC_DEFINE(ENABLE_WASM_STRIP_RECENT)
+ AC_DEFINE(ENABLE_WASM_STRIP_RECOVERYUI)
+ AC_DEFINE(ENABLE_WASM_STRIP_SPLASH)
+ AC_DEFINE(ENABLE_WASM_STRIP_SWEXPORTS)
fi
if test "$enable_wasm_exceptions" = yes; then
@@ -14623,6 +14638,7 @@ AC_CONFIG_HEADERS([config_host/config_oauth2.h])
AC_CONFIG_HEADERS([config_host/config_poppler.h])
AC_CONFIG_HEADERS([config_host/config_python.h])
AC_CONFIG_HEADERS([config_host/config_writerperfect.h])
+AC_CONFIG_HEADERS([config_host/config_wasm_strip.h])
AC_CONFIG_HEADERS([solenv/lockfile/autoconf.h])
AC_OUTPUT