summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-05-21 15:41:15 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2022-01-19 10:49:40 +0100
commit599cbdb9c2a1184680bb89aa2978e8003eca93d9 (patch)
treebc3f48e787d1bab1d74fb8fd66f4bd80bb69dc99 /configure.ac
parent9ae9b3b47c24556b2bc9a100b3bde33273018c5e (diff)
WASM more initial bits and pieces
All the small stuff, which is needed for the WASM build, but is not really worth an extra patch. * No soffice.sh script needed for WASM * WASM soffice.bin executable extension is html * Some small additional SAL_LOG output * Default to colibre icon theme * Test for qt5 even without X11 * Remove emconfigure artefacts at the end of the configure run * No oosplash for WASM * Disable the Office IPC thread * Suppress -Wno-enum-conversion for Cairo builds * Fix libnumbertext by using gb_EMSCRIPTEN_CPPFLAGS * Map EMSCRIPTEN to LINUX nls * No extra newlines for missing icon theme images * Print the missing dependency in some gbuild error messages * Copy Qt WASM loader, HTML template and SVG logo for binaries * Especially build the vcldemo for Emscripten Change-Id: I356370c72cc09357411e14d0c00762152877a800 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/128584 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7dfdb1a18062..e561a55e1a15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1121,7 +1121,7 @@ emscripten)
enable_scripting=no
enable_xmlhelp=no
with_system_zlib=no
- with_theme="breeze"
+ with_theme="colibre"
_os=Emscripten
;;
@@ -5234,6 +5234,9 @@ if test "$using_x11" = yes; then
AC_DEFINE(USING_X11)
else
disable_x11_tests
+ if test "$DISABLE_DYNLOADING" = TRUE; then
+ test_qt5=yes
+ fi
fi
else
if test "$USING_X11" = TRUE; then
@@ -14645,4 +14648,7 @@ if test -s "$WARNINGS_FILE"; then
cat "$WARNINGS_FILE"
fi
+# Remove unneeded emconfigure artifacts
+rm -f a.out a.wasm a.out.js a.out.wasm
+
dnl vim:set shiftwidth=4 softtabstop=4 expandtab: