summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-12-21 16:28:29 +0100
committerJan-Marek Glogowski <glogow@fbihome.de>2020-12-23 01:52:11 +0100
commit5de0f4e7b52e5d1c12ac658d4aedc91b9ac342cd (patch)
tree11a4c4f3072056ffcb4b89903ab025d8c315401f /configure.ac
parent7206de4f3d9eecdcbdd98294fa50f01c4c9ece9c (diff)
Don't lock galleries build into DESKTOP
And add the missing dependency of Executable_gengal on Package_svx_gengal, so the actual executable script is created in instdir_for_build for the cross-toolset. Change-Id: I98ea1d58273c871f0a3b804a93970eedfb7f8908 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108108 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a256feeac194..bffdbd69cae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2905,10 +2905,10 @@ AC_SUBST(SYSBASE)
dnl ===================================================================
dnl Sort out various gallery compilation options
dnl ===================================================================
+WITH_GALLERY_BUILD=TRUE
AC_MSG_CHECKING([how to build and package galleries])
if test -n "${with_galleries}"; then
if test "$with_galleries" = "build"; then
- WITH_GALLERY_BUILD=TRUE
AC_MSG_RESULT([build from source images internally])
elif test "$with_galleries" = "no"; then
WITH_GALLERY_BUILD=
@@ -2918,7 +2918,6 @@ if test -n "${with_galleries}"; then
fi
else
if test $_os != iOS -a $_os != Android; then
- WITH_GALLERY_BUILD=TRUE
AC_MSG_RESULT([internal src images for desktop])
else
WITH_GALLERY_BUILD=
@@ -5188,6 +5187,7 @@ if test "$cross_compiling" = "yes"; then
fi
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
+ test "$with_galleries" = "no" -o -z "$WITH_GALLERY_BUILD" && sub_conf_opts="$sub_conf_opts --with-galleries=no"
sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
# Don't bother having configure look for stuff not needed for the build platform anyway