summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <stephan.bergmann@allotropia.de>2024-01-11 17:02:43 +0100
committerMichael Stahl <michael.stahl@allotropia.de>2024-01-12 11:55:17 +0100
commitf7accbfdf3231bfa48f42533e2bcbb27b8a4af04 (patch)
treef8b0fff5fc97f770d4c03d24394e5ce2420da0e6 /configure.ac
parentf259a4636308fbdb8c5d8b9f430e3d53018f327b (diff)
Fix `make create-partial-info` (for Windows, at least)
I got lost trying to figure out how the original bin/update/create_partial_update.py code was meant to obtain old and new installation trees to diff, so I simplified that down to the create-partial-info make target now expecting an ONLINEUPDATE_MAR_OLDARCHIVE make variable that points at the old archive install set. (And the --with-online-update-mar-serverurl configure option is gone for good again.) The remaining changes are similar to what was needed in 28bad382face10be75af3875e44dde89fbc78108 "Fix `make create-update-info` (for Windows, at least)". (And the mbsdiff and mar tools expect Windows-style pathnames, but mktemp returns a Unix-style pathname in cygwin shell scripts, so this needed an additional Windows-only external/onlineupdate/cygpath.patch.) Change-Id: I40690210d62e3f26fb2d574914a0dd4323e6cd62 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/161924 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <stephan.bergmann@allotropia.de> (cherry picked from commit 44ea2602e3ed8839012582a466775f10da86ee4b) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/161937 Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 665f954adfc0..18f2900fbd39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1893,13 +1893,6 @@ libo_FUZZ_ARG_WITH(online-update-mar-certificatepath,
non-functional.)]),
,)
-libo_FUZZ_ARG_WITH(online-update-mar-serverurl,
- AS_HELP_STRING([--with-online-update-mar-serverurl=...],
- [Set the server URL value for --enable-online-update-mar.
- (Can be left off for debug purposes, even if that may render the feature
- non-functional.)]),
-,)
-
libo_FUZZ_ARG_WITH(online-update-mar-uploadurl,
AS_HELP_STRING([--with-online-update-mar-uploadurl=...],
[Set the upload URL value for --enable-online-update-mar.
@@ -13690,15 +13683,6 @@ else
fi
AC_SUBST(ONLINEUPDATE_MAR_CERTIFICATEPATH)
-AC_MSG_CHECKING([for mar online update serverurl])
-ONLINEUPDATE_MAR_SERVERURL=$with_online_update_mar_serverurl
-if test -n "$ONLINEUPDATE_MAR_SERVERURL"; then
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ONLINEUPDATE_MAR_SERVERURL)
-
AC_MSG_CHECKING([for mar online update uploadurl])
ONLINEUPDATE_MAR_UPLOADURL=$with_online_update_mar_uploadurl
if test -n "$ONLINEUPDATE_MAR_UPLOADURL"; then