summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@collabora.com>2013-09-18 19:06:20 -0400
committerKohei Yoshida <kohei.yoshida@collabora.com>2013-09-18 22:37:58 -0400
commit02346aa4663055e1adf7c52ede89871a493f4513 (patch)
treeb7ada15067c5afe5ca5527533accd996ceb90328 /configure.ac
parent90698b5f6721472ebcdda2bb7c34e7364c3da9eb (diff)
Add the configure bits to support --disable-orcus.
Change-Id: Ieeb1581187248875ca2e37278c62a382f6caa8e0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac86
1 files changed, 52 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index fda58df807cd..141d0e18d86b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -729,6 +729,11 @@ AC_ARG_ENABLE(graphite,
[Enables the compilation of Graphite smart font rendering.])
)
+AC_ARG_ENABLE(orcus,
+ AS_HELP_STRING([--enable-orcus],
+ [Enables orcus for extra file import filters for Calc.])
+)
+
AC_ARG_ENABLE(fetch-external,
AS_HELP_STRING([--disable-fetch-external],
[Disables fetching external tarballs from web sources.])
@@ -8941,6 +8946,52 @@ fi
AC_SUBST(ENABLE_GRAPHITE)
dnl ===================================================================
+dnl Orcus
+dnl ===================================================================
+
+AC_MSG_CHECKING([whether to enable orcus])
+if test $_os != Darwin -a $_os != Android -a $_os != iOS -a \( -z "$enable_orcus" -o "$enable_orcus" != no \); then
+ AC_MSG_RESULT([yes])
+ ENABLE_ORCUS="TRUE"
+ AC_DEFINE(ENABLE_ORCUS)
+
+ libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.6 >= 0.5.0])
+ if test "$with_system_orcus" != "yes"; then
+ if test "$SYSTEM_BOOST" = "YES"; then
+ # ===========================================================
+ # Determine if we are going to need to link with Boost.System
+ # ===========================================================
+ dnl This seems to be necessary since boost 1.50 (1.48 does not need it,
+ dnl 1.49 is untested). The macro BOOST_THREAD_DONT_USE_SYSTEM mentioned
+ dnl in documentation has no effect.
+ AC_MSG_CHECKING([if we need to link with Boost.System])
+ AC_LANG_PUSH([C++])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ @%:@include <boost/version.hpp>
+ ]],[[
+ #if BOOST_VERSION >= 105000
+ # error yes, we need to link with Boost.System
+ #endif
+ ]])],[
+ AC_MSG_RESULT([no])
+ ],[
+ AC_MSG_RESULT([yes])
+ AX_BOOST_SYSTEM
+ ])
+ AC_LANG_POP([C++])
+ fi
+ fi
+ dnl FIXME by renaming SYSTEM_LIBORCUS to SYSTEM_ORCUS in the build system world
+ SYSTEM_LIBORCUS=$SYSTEM_ORCUS
+ AC_SUBST([BOOST_SYSTEM_LIB])
+ AC_SUBST(SYSTEM_LIBORCUS)
+
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_ORCUS)
+
+dnl ===================================================================
dnl HarfBuzz
dnl ===================================================================
AC_MSG_CHECKING([whether to enable HarfBuzz support])
@@ -9210,40 +9261,6 @@ AC_SUBST(RASQAL_MAJOR)
AC_SUBST(REDLAND_MAJOR)
dnl ===================================================================
-dnl Check for system orcus
-dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.6 >= 0.5.0])
-if test "$with_system_orcus" != "yes"; then
- if test "$SYSTEM_BOOST" = "YES"; then
- # ===========================================================
- # Determine if we are going to need to link with Boost.System
- # ===========================================================
- dnl This seems to be necessary since boost 1.50 (1.48 does not need it,
- dnl 1.49 is untested). The macro BOOST_THREAD_DONT_USE_SYSTEM mentioned
- dnl in documentation has no effect.
- AC_MSG_CHECKING([if we need to link with Boost.System])
- AC_LANG_PUSH([C++])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- @%:@include <boost/version.hpp>
- ]],[[
- #if BOOST_VERSION >= 105000
- # error yes, we need to link with Boost.System
- #endif
- ]])],[
- AC_MSG_RESULT([no])
- ],[
- AC_MSG_RESULT([yes])
- AX_BOOST_SYSTEM
- ])
- AC_LANG_POP([C++])
- fi
-fi
-dnl FIXME by renaming SYSTEM_LIBORCUS to SYSTEM_ORCUS in the build system world
-SYSTEM_LIBORCUS=$SYSTEM_ORCUS
-AC_SUBST([BOOST_SYSTEM_LIB])
-AC_SUBST(SYSTEM_LIBORCUS)
-
-dnl ===================================================================
dnl Check for system hunspell
dnl ===================================================================
AC_MSG_CHECKING([which libhunspell to use])
@@ -12571,6 +12588,7 @@ AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_lgpl.h])
AC_CONFIG_HEADERS([config_host/config_mpl.h])
+AC_CONFIG_HEADERS([config_host/config_orcus.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])