summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-10-11 13:11:50 +0300
committerTor Lillqvist <tml@collabora.com>2013-10-11 13:15:05 +0300
commit1a56bda2aa8d1aea587aec8021e4380abf0effb3 (patch)
treeae19b21ea3dc20ea2ca22f22af34cbf4823c3b65 /configure.ac
parent7d879c775c3212193c4703ae57940630dad8800e (diff)
Small fix for cross-compilation
Change-Id: I5851af308193527a30eef1ded256f6b9ae69b260
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f45152e20db9..0ec35cf1d065 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4489,19 +4489,23 @@ if test "$cross_compiling" = "yes"; then
echo
rm -rf CONF-FOR-BUILD config_build.mk
mkdir CONF-FOR-BUILD
+ # Here must be listed all files needed when running the configure script. In particular, also
+ # those expanded by the AC_CONFIG_FILES() call near the end of this configure.ac. For clarity,
+ # keep them in the same order as there.
(cd $SRC_ROOT && tar cf - \
config.guess \
+ bin/get_config_variables \
+ solenv/bin/getcompver.awk \
+ solenv/inc/langlist.mk \
config_host.mk.in \
Makefile.in \
lo.xcent.in \
+ instsetoo_native/util/openoffice.lst.in \
config_host/*.in \
- bin/get_config_variables \
- solenv/bin/getcompver.awk \
- solenv/inc/langlist.mk \
- instsetoo_native/util/openoffice.lst.in) \
+ sysui/desktop/macosx/Info.plist.in) \
| (cd CONF-FOR-BUILD && tar xf -)
cp configure CONF-FOR-BUILD
- test -d config_build && cp -p config_build/*.h CONF-FOR-BUILD/config_host
+ test -d config_build && cp -p config_build/*.h CONF-FOR-BUILD/config_host 2>/dev/null
(
unset COM GUIBASE OS CPU CPUNAME
unset CC CXX SYSBASE CFLAGS