summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2015-10-29 15:37:45 +0100
committerAndras Timar <andras.timar@collabora.com>2015-11-02 20:52:31 +0100
commit79f3a7bfefb8decd2d18df21d799f2d9241a44c3 (patch)
tree47958ba37f5582144da54bece44e5765f697931f /configure.ac
parentb577b5b505138ecb90e1e9e6405de86b503afd59 (diff)
OSX issues with space in product name
Change-Id: I0155372c8e5cd0eb91bfbea304190502cbf32e3c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dcd62d121c2a..54ad87311f7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -667,7 +667,8 @@ darwin*) # Mac OS X or iOS
test_cups=no
else
_os=Darwin
- INSTROOTSUFFIX=/$PRODUCTNAME.app/Contents
+ ONEWORDPRODUCTNAME=`echo "${PRODUCTNAME// /}"`
+ INSTROOTSUFFIX=/$ONEWORDPRODUCTNAME.app/Contents
SDKDIRNAME=AC_PACKAGE_NAME${PRODUCTVERSION}_SDK
fi
enable_systray=no
@@ -12454,7 +12455,7 @@ else
fi
AC_SUBST(WITH_COMPAT_OOWRAPPERS)
-INSTALLDIRNAME=`echo AC_PACKAGE_NAME | $AWK '{print tolower($0)}'`
+INSTALLDIRNAME=`echo AC_PACKAGE_NAME | $AWK '{gsub(" ", "", $0);print tolower($0)}'`
AC_MSG_CHECKING([for install dirname])
if test -n "$with_install_dirname" -a "$with_install_dirname" != "no" -a "$with_install_dirname" != "yes"; then
INSTALLDIRNAME="$with_install_dirname"