summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <thorsten.behrens@cib.de>2015-04-02 00:54:05 +0200
committerThorsten Behrens <thorsten.behrens@cib.de>2015-04-02 00:55:45 +0200
commit7b45c5cc05ae1d38d3e201153badefab845dfcc1 (patch)
treec3d9ea8358d202d26861756093171168fb4ec077 /configure.ac
parentf77a138e381ac5a6c349df29c97b00d8ee69959e (diff)
Make configure actually find LODE nasm
Change-Id: I7650a56375d98814e89fc21894c92a200832bb29
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0dbf5ac9e91a..4189d51ea4f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7440,8 +7440,13 @@ else
AC_MSG_RESULT([internal, jpeg-turbo])
BUILD_TYPE="$BUILD_TYPE JPEG_TURBO"
AC_CHECK_PROGS(NASM, [nasm nasmw yasm])
- if test -z "$NASM" -a "$build_os" = "cygwin" -a -x "/opt/lo/bin/nasm"; then
- NASM="/opt/lo/bin/nasm"
+
+ if test -z "$NASM" -a "$build_os" = "cygwin"; then
+ if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/nasm"; then
+ NASM="$LODE_HOME/opt/bin/nasm"
+ elif -x "/opt/lo/bin/nasm"; then
+ NASM="/opt/lo/bin/nasm"
+ fi
fi
if test -z "$NASM"; then
cat << _EOS