summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-12-31 22:52:47 +0100
committerJan-Marek Glogowski <glogow@fbihome.de>2022-01-01 11:50:02 +0100
commit1bb248fa3670ac11d4623ba14d1e914554fb6971 (patch)
treee721288fbd06de321ea3eace6dec6c6cd6db3e43 /configure.ac
parent42834bec6ba590f060e74c23324d362bf8d4fd1a (diff)
gbuild: silence Windows Skia clang builds
When building Skia on Windows in an non-English environment, the console is filled with "Note: including file:" output. That's because cl.exe has some translated output, but clang.exe has not. So detect the clang usage and its "showIncludes" output and override that setting for the compiler call. Change-Id: I19b403aa79a8dde70616865aef051aa365f79de6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/127822 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d3df0f0b3d4..fb8d85a01f71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12041,6 +12041,17 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
else
AC_MSG_RESULT([no])
fi
+
+ AC_MSG_CHECKING([the dependency generation prefix (clang.exe -showIncludes)])
+ echo "#include <stdlib.h>" > conftest.c
+ LO_CLANG_SHOWINCLUDES_PREFIX=`$LO_CLANG_CC $CFLAGS -c -showIncludes conftest.c 2>/dev/null | \
+ grep 'stdlib\.h' | head -n1 | sed 's/ [[[:alpha:]]]:.*//'`
+ rm -f conftest.c conftest.obj
+ if test -z "$LO_CLANG_SHOWINCLUDES_PREFIX"; then
+ AC_MSG_ERROR([cannot determine the -showIncludes prefix])
+ else
+ AC_MSG_RESULT(["$LO_CLANG_SHOWINCLUDES_PREFIX"])
+ fi
else
AC_CHECK_PROG(LO_CLANG_CC,clang,clang,[])
AC_CHECK_PROG(LO_CLANG_CXX,clang++,clang++,[])
@@ -12348,6 +12359,7 @@ AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_AVX512)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_AVX512F)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_F16C)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_FMA)
+AC_SUBST(LO_CLANG_SHOWINCLUDES_PREFIX)
AC_SUBST(CLANG_USE_LD)
AC_SUBST([HAVE_LO_CLANG_DLLEXPORTINLINES])