summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Mencken <dougmencken@gmail.com>2013-12-18 13:40:46 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-12-19 13:42:20 +0000
commitd70f5d1e5477f3fce6cf35884b3cecb260d504e1 (patch)
tree019e935085f7d5e2aa07620f6cdefd29d919aa35 /configure.ac
parent15abebbde560e17413f17b16b8b2e9c1f31f01a5 (diff)
Don't enable OpenCL on OS X 10.5
Change-Id: I5b74d9a043c793ff5176b10786c09041207509a6 Reviewed-on: https://gerrit.libreoffice.org/7138 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 534894a3e383..1734796ed26f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10448,13 +10448,15 @@ AC_MSG_CHECKING([whether to build with the OpenCL support.])
ENABLE_OPENCL=
if test $_os != iOS -a $_os != Android -a "x$enable_opencl" != "xno"; then
- AC_MSG_RESULT([yes])
- enable_opencl=yes
- ENABLE_OPENCL=TRUE
- AC_DEFINE(HAVE_FEATURE_OPENCL)
+ if test $_os = Darwin -a "$with_macosx_sdk" = "10.5"; then
+ AC_MSG_RESULT([disabled on OS X 10.5])
+ else
+ AC_MSG_RESULT([yes])
+ ENABLE_OPENCL=YES
+ AC_DEFINE(HAVE_FEATURE_OPENCL)
+ fi
else
AC_MSG_RESULT([no])
- enable_opencl=no
fi
AC_SUBST(ENABLE_OPENCL)