summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-10-02 17:54:03 +0200
committerMichael Stahl <mstahl@redhat.com>2014-10-02 20:00:17 +0200
commit86cd29772e4f0571149c479378164572fbc96034 (patch)
tree8f6334813634bbb4324c5be25cb43f6e13156d58 /configure.ac
parent78766aaa12ae4fae9dd2f3274617ba41de57eefd (diff)
remove HAVE_GCC_PRAGMA_DIAGNOSTIC_MODIFY check and macro
This has been supported by GCC and clang for a very long time. Change-Id: I410a2b39004c932003f8cbefe935aedb109b1163
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 4b1f554ba86a..44ee065d2a58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5789,19 +5789,6 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING(
- [whether $CC supports pragma GCC diagnostic error/ignored/warning])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -Wunknown-pragmas -Wunused-parameter"
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #pragma GCC diagnostic ignored "-Wunused-parameter"
- void dummy(int n) {}
- ])], [
- AC_DEFINE([HAVE_GCC_PRAGMA_DIAGNOSTIC_MODIFY],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
- CFLAGS=$save_CFLAGS
-
AC_MSG_CHECKING([whether $CC supports pragma GCC diagnostic push/pop])
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror -Wunknown-pragmas -Wunused-parameter"