summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2021-11-29 20:11:37 +0100
committerLuboš Luňák <l.lunak@collabora.com>2021-11-30 10:38:10 +0100
commitc73aa8bd54ca5d1aba5fa0c1e15837b77c673861 (patch)
treeaf65d0ccc0211b1b7190fa7f620fe131d52de1dd /configure.ac
parentcb14adfd8cd593da4c429fcefba48531c10e47ac (diff)
try to find clang-cl also in C:/Program Files/LLVM
That's where the LLVM installer puts it by default. Change-Id: Ia20979a4ae97eca8686b7a82a372264750066f63 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126081 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 140ee52e675f..2c5a8808a9ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12069,6 +12069,12 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
AC_MSG_CHECKING([for clang-cl])
if test -x "$VC_PRODUCT_DIR/Tools/Llvm/bin/clang-cl.exe"; then
LO_CLANG_CC=`win_short_path_for_make "$VC_PRODUCT_DIR/Tools/Llvm/bin/clang-cl.exe"`
+ elif test -n "$PROGRAMFILES" -a -x "$PROGRAMFILES/LLVM/bin/clang-cl.exe"; then
+ LO_CLANG_CC=`win_short_path_for_make "$PROGRAMFILES/LLVM/bin/clang-cl.exe"`
+ elif test -x "c:/Program Files/LLVM/bin/clang-cl.exe"; then
+ LO_CLANG_CC=`win_short_path_for_make "c:/Program Files/LLVM/bin/clang-cl.exe"`
+ fi
+ if test -n "$LO_CLANG_CC"; then
dnl explicitly set -m32/-m64
LO_CLANG_CC="$LO_CLANG_CC -m$WIN_HOST_BITS"
LO_CLANG_CXX="$LO_CLANG_CC"