summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2018-02-17 17:22:59 +0200
committerAndras Timar <andras.timar@collabora.com>2018-03-25 20:11:02 +0200
commitcb75f14a446ae2f59e65414c3ac078068762e92c (patch)
tree66c41415e20f4e2727bced0534af2200cc7baf78 /configure.ac
parent2a664263d043f0327a92d5d5f7507bd10143fd31 (diff)
tdf#115283: Avoid bashism
(We do require bash for other parts of the build, though, and have no plans to change that. But let's make the bug reporter happy here.) Change-Id: I4bcd3a86fb4e6f95d4eec8557faf359bf5549c03 (cherry picked from commit c902cbc7dc5294ab721a9aef3a152aa243d00011)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 87b996dbb293..f8394c9677a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,7 +169,7 @@ if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
fi
AC_MSG_RESULT([$PRODUCTNAME])
AC_SUBST(PRODUCTNAME)
-PRODUCTNAME_WITHOUT_SPACES=${PRODUCTNAME// /}
+PRODUCTNAME_WITHOUT_SPACES=$(echo "$PRODUCTNAME" | sed 's/ //g')
AC_SUBST(PRODUCTNAME_WITHOUT_SPACES)
dnl ===================================================================