summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKatarina Behrens <Katarina.Behrens@cib.de>2017-01-30 15:50:55 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2017-02-01 12:11:22 +0000
commit595848c85acc2609fcc48a40c7a9f216a2722cd8 (patch)
tree9bfdbff5ed6b9650c4089ac2115d53a5764d3ae3 /configure.ac
parentee32c7d8083ae1449d6b379034be92995c142da9 (diff)
gpg4libre: Support building --with-system-gpgme (Linux only so far)
Change-Id: I22af89b920d43f3fc5f0fff02070f288bfa59fb4 Reviewed-on: https://gerrit.libreoffice.org/33702 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Siegmund Gorr <siegmund.gorr@cib.de> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e8551c801e88..93896d73495f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1721,6 +1721,11 @@ AC_ARG_WITH(system-poppler,
[Use system poppler (only needed for PDF import).]),,
[with_system_poppler="$with_system_libs"])
+AC_ARG_WITH(system-gpgme,
+ AS_HELP_STRING([--with-system-gpgme],
+ [Use gpgme already on system]),,
+ [with_system_gpgme="$with_system_libs"])
+
AC_ARG_WITH(system-apache-commons,
AS_HELP_STRING([--with-system-apache-commons],
[Use Apache commons libraries already on system.]),,
@@ -10622,6 +10627,29 @@ AC_SUBST(SYSTEM_POPPLER)
AC_SUBST(POPPLER_CFLAGS)
AC_SUBST(POPPLER_LIBS)
+SYSTEM_GPGME=
+if test "$_os" = "Linux"; then
+ dnl ===================================================================
+ dnl Check for system gpgme
+ dnl ===================================================================
+ AC_MSG_CHECKING([which gpgme to use])
+ if test "$with_system_gpgme" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_GPGME=TRUE
+
+ AC_PATH_PROG(GPGMECONFIG, gpgme-config)
+ if test -z "$GPGMECONFIG"; then
+ AC_MSG_ERROR([--with-system-gpgme requested, but gpgme programs not found])
+ fi
+
+ GPGME_CFLAGS=`$GPGMECONFIG --cflags`
+ GPGME_LIBS=`$GPGMECONFIG --libs`
+ fi
+fi
+AC_SUBST(SYSTEM_GPGME)
+AC_SUBST(GPGME_CFLAGS)
+AC_SUBST(GPGME_LIBS)
+
AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
if test "x$enable_ext_wiki_publisher" = "xyes" -a "x$enable_extension_integration" != "xno" -a "$with_java" != "no"; then
AC_MSG_RESULT([yes])