summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-11-24 21:58:54 +0100
committerStephan Bergmann <sbergman@redhat.com>2015-11-28 08:44:35 +0100
commit1cb6ab10f9ace1ce34b72de096885d529fe0d5d0 (patch)
tree73eda13e3e800a392c5f2aebebdbe976e1e49b51 /configure.ac
parent269a3e5c4d9a7b6a15fc7c86ef8bef1dbfe92f7c (diff)
Check HAVE_GCC_PRAGMA_OPERATOR for clang-cl, too
Change-Id: I71997ca604f18601ec98acd2957882a26be38fc0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e00df9594f46..01d24e93d813 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6359,7 +6359,7 @@ fi
HAVE_GCC_PRAGMA_OPERATOR=
dnl _Pragma support (may require C++11)
-if test "$GCC" = "yes"; then
+if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_CHECKING([whether $CXX supports _Pragma operator])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS