summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan iversen <jani@documentfoundation.org>2015-11-28 14:12:17 +0100
committerMichael Meeks <michael.meeks@collabora.com>2015-11-30 09:20:44 +0000
commit75892872496175d71b4ad02c1a477dc9f463d803 (patch)
tree1e978e9f982b364d76128fac9ec8d403e75c514e /configure.ac
parent628d84d9a82bd2759faf869d7a28233538094578 (diff)
check for missing COMSPEC variable in cygwin.
Cygwin unsets the COMSPEC environment variable on some installations. This is due to an error reported first time in 2005, but not solved. There are no exact pattern when this happens, in this case it happened on 2 windows 8.1 VM installations (one private one azure). added check in configure.ac to alert the user earlier COMSPEC is used in sal/osl to start processes and as such vital, and in some perl scripts, therefore hardcoding to e.g. cmd32.exe (or the power shell) is not an option. Limited check to work only for cygwin. Change-Id: I52bb6667c52560ed1a239ac301811605b8cddcbf Reviewed-on: https://gerrit.libreoffice.org/20255 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Meeks <michael.meeks@collabora.com> Tested-by: Michael Meeks <michael.meeks@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71f2037e7663..9a13921411ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,10 @@ if test "$build_os" = "cygwin"; then
PathFormat "$BUILDDIR"
BUILDDIR="$formatted_path"
x_Cygwin=
+ AC_MSG_CHECKING(for explicit COMSPEC)
+ if test -z "$COMSPEC"; then
+ AC_MSG_ERROR([COMSPEC not set in Environment, please set it an rerun])
+ fi
fi
AC_SUBST(SRC_ROOT)