summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2019-06-05 02:06:00 +0300
committerAndras Timar <andras.timar@collabora.com>2019-11-19 23:59:10 +0100
commitdce3478ab53b679f4a6a8d8a903cb6a2e938dbd1 (patch)
treeedd55a3d08ab72606ad91f82c14c65738070c822 /configure.ac
parent235b3ce4a6158993e535aa3fb56c0d4753becd0c (diff)
The Bluetooth code doesn't compile with macOS SDK 10.15
Change-Id: I8fffa4cef9628e6872c881cd0cbdfe85495fa324
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bfcc32b65d2e..e10bf8849044 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10198,6 +10198,10 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
ENABLE_SDREMOTE=TRUE
AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
+ if test $OS = MACOSX -a "$MAC_OS_X_VERSION_MAX_ALLOWED" -ge 101500; then
+ # The Bluetooth code doesn't compile with macOS SDK 10.15
+ enable_sdremote_bluetooth=no
+ fi
# If not explicitly enabled or disabled, default
if test -z "$enable_sdremote_bluetooth"; then
case "$OS" in