summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-05-31 15:24:34 +0200
committerLuboš Luňák <l.lunak@suse.cz>2013-06-28 14:49:44 +0200
commit833db52c5cb38c0ae61f80db98191eea08e2f6f3 (patch)
tree1d7330fc715345881fb2a520db93782b29e1e1da /configure.ac
parenta0f87de207c27785e1c9a4b4f11bbe8b704990b9 (diff)
configure: use -isystem for GSTREAMER_CFLAGS
... to work around GCC 4.8.0 -Werror=literal-suffix in gst/video/video.h definition of GST_VIDEO_CAPS_RGB8_PALETTED. Change-Id: I514b29d58f348bad0b13c7ef66db4b3ee34516cd (cherry picked from commit 18b0bda1be62da1b0f9c1fc40864ccc486d5b43c) Signed-off-by: Luboš Luňák <l.lunak@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92f0cfa07d83..e4c6827059ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9614,6 +9614,7 @@ if test "$build_gstreamer" = "yes"; then
ENABLE_GSTREAMER="TRUE"
AC_MSG_RESULT([yes])
PKG_CHECK_MODULES( GSTREAMER, gstreamer-1.0 gstreamer-plugins-base-1.0 gstreamer-video-1.0 )
+ GSTREAMER_CFLAGS="`echo $GSTREAMER_CFLAGS | sed -e \"s/-I/${ISYSTEM}/g\"`"
else
AC_MSG_RESULT([no])
fi
@@ -9633,6 +9634,7 @@ if test "$build_gstreamer_0_10" = "yes"; then
PKG_CHECK_MODULES( [GSTREAMER_0_10], [gstreamer-0.10 gstreamer-plugins-base-0.10 gstreamer-interfaces-0.10],, [
PKG_CHECK_MODULES( [GSTREAMER_0_10], [gstreamer-0.10 gstreamer-plugins-base-0.10] )
])
+ GSTREAMER_0_10_CFLAGS="`echo $GSTREAMER_0_10_CFLAGS | sed -e \"s/-I/${ISYSTEM}/g\"`"
else
AC_MSG_RESULT([no])
fi