summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@libreoffice.org>2023-07-19 08:29:27 +0300
committerخالد حسني <khaled@libreoffice.org>2023-07-23 06:04:24 +0200
commit063d71f4d3a145a5e28b26c6e5d1a7ae5b5f8891 (patch)
tree90a7ec444fa79b56b534e2271646ee82f1a69f02 /configure.ac
parentecf352701411fe178b51841b5714e27bef500206 (diff)
Drop --enable-float-device-pixel configure option
This does nothing now, as we are now always using doubles for VCL glyph coordinates. Change-Id: I87e4e3057dbc54a2ecf0924d3d6a408cf519f842 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/154631 Tested-by: Jenkins Reviewed-by: خالد حسني <khaled@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 3ffb5fd42613..3dea1ce2bd47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2076,11 +2076,6 @@ AC_ARG_ENABLE(customtarget-components,
AS_HELP_STRING([--enable-customtarget-components],
[Generates the static UNO object constructor mapping from the build.]))
-AC_ARG_ENABLE(float_device_pixel,
- AS_HELP_STRING([--enable-float-device-pixel],
- [Uses doubles for VCL device coordinates instead of 32-bit integers.]),
-,)
-
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -9287,7 +9282,6 @@ else
AC_MSG_RESULT([yes])
ENABLE_FUZZERS="TRUE"
AC_DEFINE([ENABLE_FUZZERS],1)
- AC_DEFINE([VCL_FLOAT_DEVICE_PIXEL],1)
BUILD_TYPE="$BUILD_TYPE FUZZERS"
fi
AC_SUBST(LIB_FUZZING_ENGINE)
@@ -11674,18 +11668,6 @@ EPOXY_CFLAGS_internal="-I${WORKDIR}/UnpackedTarball/epoxy/include"
libo_CHECK_SYSTEM_MODULE([epoxy], [EPOXY], [epoxy >= 1.2])
dnl ===================================================================
-dnl Set vcl option: coordinate device in double or sal_Int32
-dnl ===================================================================
-
-AC_MSG_CHECKING([Type to use for Device Pixel coordinates])
-if test "$enable_float_device_pixel" = yes; then
- AC_DEFINE(VCL_FLOAT_DEVICE_PIXEL)
- AC_MSG_RESULT([double])
-else
- AC_MSG_RESULT([sal_Int32])
-fi
-
-dnl ===================================================================
dnl Show which vclplugs will be built.
dnl ===================================================================
R=""
@@ -14991,7 +14973,6 @@ AC_CONFIG_HEADERS([config_host/config_skia.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
AC_CONFIG_HEADERS([config_host/config_validation.h])
AC_CONFIG_HEADERS([config_host/config_vendor.h])
-AC_CONFIG_HEADERS([config_host/config_vcl.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_CONFIG_HEADERS([config_host/config_oauth2.h])