summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2013-08-29 21:23:49 +0200
committerRene Engelhard <rene@debian.org>2013-08-29 21:24:53 +0200
commit0d5b9f1ad4b132d8d0cc22af1f524f971c0166db (patch)
tree018cb1ef5b5dfb4707e3cec153e8dd379bd62065 /configure.ac
parentb1a6dbc2dd118627360282dd304e24263c3bca51 (diff)
check for boost >= 1.47 and SHA512_CTX (openssl >= 0.9.8) in configure
Change-Id: If070d0bcafb208bb8d4104e48540cc1b2bf23db6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 89ce3f7a11f5..ef10c7017e4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8523,7 +8523,7 @@ AC_MSG_CHECKING([which boost to use])
if test "$with_system_boost" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_BOOST=YES
- AX_BOOST_BASE
+ AX_BOOST_BASE(1.47)
AX_BOOST_DATE_TIME
mingw_boost_date_time_dll=`echo $BOOST_DATE_TIME_LIB | sed -e 's/^-l//' -e 's/\.dll$//'`
libo_MINGW_TRY_DLL([$mingw_boost_date_time_dll])
@@ -9139,6 +9139,12 @@ if test "$enable_openssl" = "yes"; then
if test "$with_system_openssl" = "yes"; then
libo_MINGW_CHECK_DLL([libssl])
libo_MINGW_CHECK_DLL([libcrypto])
+ AC_MSG_CHECKING([whether openssl supports SHA512])
+ AC_LANG_PUSH([C])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/sha.h>]],[[
+ SHA512_CTX context;
+]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([no, openssl too old. Need >= 0.9.8.])])
+ AC_LANG_POP(C)
fi
else
AC_MSG_RESULT([yes])