summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-01-23 17:57:44 +0100
committerStephan Bergmann <sbergman@redhat.com>2019-01-23 21:06:51 +0100
commit1dcdb9b538b3afb3e439d780baa15e5eba4af31f (patch)
treeeb98b70363123bc2e1dd7af58b8a878a39c64999 /configure.ac
parentbcb1969f961874ccbcef7fc042b3cc164c8d2325 (diff)
Drop use of obsolete GCC -fno-default-inline
...that is documented as: "Does nothing. Preserved for backward compatibility." ever since <https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=160384> from 2010. -fno-default-inline was the only value ever set in gb_DEBUG_CXXFLAGS, so the latter can be removed now. The use of gb_DEBUG_CXXFLAGS had accidentally already been removed from gb_LinkTarget__get_debugcxxflags with e751e24250fda31dde52b3c65ca79f86142dc789 "--enable-optimized should be orthogonal to --enable-debug/--enable-dbgutil", and that leaves gb_LinkTarget__get_debugcflags and gb_LinkTarget__get_debugcxxflags with identical definitions, so replace those two with a single gb_LinkTarget__get_debugflags. Some external modules had used only gb_DEBUG_CXXFLAGS, when this was apparently meant to be used in addition to gb_DEBUG_CFLAGS, so those uses have been changed to gb_DEBUG_CFLAGS now. Change-Id: I84ea0ab1233569b0b02ca057240a71f138352381 Reviewed-on: https://gerrit.libreoffice.org/66808 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 19f1f5803d5e..a0cda0719711 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6711,22 +6711,8 @@ dnl ===================================================================
dnl Clang++ tests
dnl ===================================================================
-HAVE_GCC_FNO_DEFAULT_INLINE=
HAVE_GCC_FNO_ENFORCE_EH_SPECS=
if test "$GCC" = "yes"; then
- AC_MSG_CHECKING([whether $CXX supports -fno-default-inline])
- AC_LANG_PUSH([C++])
- save_CXXFLAGS=$CXXFLAGS
- CXXFLAGS="$CFLAGS -Werror -fno-default-inline"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_FNO_DEFAULT_INLINE=TRUE ],[])
- CXXFLAGS=$save_CXXFLAGS
- AC_LANG_POP([C++])
- if test "$HAVE_GCC_FNO_DEFAULT_INLINE" = "TRUE"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-
AC_MSG_CHECKING([whether $CXX supports -fno-enforce-eh-specs])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
@@ -6740,7 +6726,6 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
fi
-AC_SUBST(HAVE_GCC_FNO_DEFAULT_INLINE)
AC_SUBST(HAVE_GCC_FNO_ENFORCE_EH_SPECS)
dnl ===================================================================